今天在编写一个Flutter插件时,尝试flutter build ios时提示了cocopods版本过低,如下

[!] The version of CocoaPods used to generate the lockfile (1.6.1) is higher than the version of the current executable (1.6.0.beta.2). Incompatibility issues may arise.

升级过程中发现ruby-china的域名改了(目测国内org现在无法备案了,包括本站的.me域名).

记录下升级过程
查看当前cocopods版本

pod --version

移除之前的org域名镜像

gem sources --remove https://gems.ruby-china.org/

添加新的域名

gem sources -a https://gems.ruby-china.com/

查看源

gem source -l

升级cocoapods

sudo gem install cocoapods

再次查看cocoapods版本

pod --version

标签: flutter, cocoapods, flutter build ios, ruby-china.org

添加新评论